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Getting Started with OpenSCAD
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Introduction to OpenSCAD
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OpenSCAD is a solid 3D modeler that allows you to create parametric models using its scripting language. You can create models by transforming and combining simple shapes. In OpenSCAD, everything is controlled by the parameters. For example, if you want to change the position of the hole shown in the figure, you need to change the X distance value of the translate () function.
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The parameters that you set up allow you to have control over the design intent. The design intent describes the way your 3D model will behave when you modify the dimensions of the model. For example, if you want to position the hole at the center of the block, one way is to manually change the x distance value of the translate () function. However, when you change the size of the cube, the hole will not be at the center. 
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You can make the hole to be at the center, even if the size of the cube changes. To do this, you need to create the parameters of the model at the beginning of the script, as shown. Next, use the parameters in place of the values in the script. For example, change the x and z values of the translate () function to the cube_width/2 and cube_height/2, respectively.
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Now, even if you change the size of the cube, the hole will always remain at the center.
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User Interface
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The following image shows the OpenSCAD window.
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Toolbars in OpenSCAD
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There are two toolbars available in OpenSCAD: File and View.

The File toolbar has options to create files, open, save, render, and export files.
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The View toolbar has the icons to modify the display of the model.

[image: image]



	[image: image]

	View All

	The model will be fitted in the current size of the graphics window so that it will be visible completely.


	
	Rotate

	Press and hold the left mouse button. Next, drag the pointer to rotate the model view.
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	Zoom In

	Click this icon to the zoom in to the model.
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	Zoom Out

	Click this icon to zoom out of the model.
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	Perspective

	This icon allows you to switch to the perspective projection of the model.
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	Orthogonal

	This icon allows you to switch to the parallel projection of the model.
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	Reset View

	This icon allows you to reset the view orientation to Isometric.
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	Right

	This icon allows you to change the view orientation to right.
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	Top

	This icon allows you to change the view orientation to top.
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	Bottom

	Click this icon to change the view orientation to the bottom.


	[image: image]

	Left

	Click this icon to change the view orientation to the left.
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	Front

	Click this icon to change the view orientation to the front.
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	Back

	Click this icon to change the view orientation to back.
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Menu Bar
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The menu bar is located at the top left corner of the window. It consists of File, Edit, Design, View, and Help menus. 
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Editor window
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The Editor window is located on the left side. It is used to enter the script to create the 2D and 3D objects.
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3D View window
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The 3D View window is located on the right side of the Editor window. It displays the 3D Model generated from the script that you enter in the Editor window.

	[image: image]
	 	[image: image]


[image: image]

OpenSCAD Help
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OpenSCAD offers you the help system that goes beyond basic command definition. You can access OpenSCAD help by clicking on the Help menu icon on the right side of the window. 
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Tutorial 1
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In this example, you create the part shown below.

[image: 43.jpg]
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Creating a New Document
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	Click the Windows icon located at the bottom left corner of the desktop. Next, click O > OpenSCAD.


[image: image]

	Click the New button on the Welcome to OpenSCAD dialog.
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Creating a 3D Cube
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	On the menu bar, click Help > Cheat Sheet.

	On the Cheet Sheet page, select the cube([width,depth,height], center) from the 3D section.

	Next, right-click and select Copy.
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	Switch to the OpenSCAD window. Next, right-click in the Editor and select Paste.

	Change the width, depth, and height values to 50, 65, and 40, respectively. 

	Click next to center and type =false; the cube will not be created at the center of the 3D View window.

	Add semicolon ‘;’ at the end of the script.
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	Click the Render icon on the File toolbar; the model is rendered. 

	Click the View all icon on the View toolbar; the model is fitted in the 3D View window.
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Creating Cuts on the Cube
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Now, you need to create a cut on the cube using another cube. To do this, you need to create a cube, and then translate it to the required position. Next, subtract the cube from the first cube using the difference () Boolean operation.

	Click next to the semicolon of the cube function and Press ENTER.

	Type translate ([12,0,14]) and then press ENTER.

	Type cube ([38,65,12], center=false); and then press ENTER. A cube of 38 width, 65 depth, and 12 height will be created. Also, it will be translated to the distance of 12 in the X direction, 0 in the Y direction, and 14 in the Z direction.
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	Click before the first cube.

	Type difference(){ and press ENTER.

	Close the parentheses at the end of the script, as shown.
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	Click the Render icon on the View toolbar; the model is rendered. 
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	Select the translate and cube function. Next, right-click and select Copy.

	Click next to the semicolon of the last cube function and press ENTER.

	Right-click and select Paste.
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	Change the values of the translate and cube functions, as shown.

	Click the Render[image: image] icon on the View toolbar; the model is rendered. 
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	Select the translate and cube function. Next, right-click and select Copy.

	Click next to the semicolon of the last cube function and press ENTER.

	Right-click and select Paste.

	Change the values of the translate and cube functions, as shown.

	Click the Render[image: image] icon on the View toolbar; the model is rendered.
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Adding a Cube to the model
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Now, you will add a cube to the model using the cube, translate, and union functions.

	Click at the beginning of the script and press ENTER.

	Type union(){.


	Click at the end of the script and press ENTER. Next, type translate ([50,40,0]) and then press ENTER.


	Type cube ([12,25,14], center=false); and then press ENTER.

	Close the parentheses at the end of the script, as shown.

	Click the Render[image: image] icon on the View toolbar; the model is rendered.
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	Click the Save icon on the File toolbar. Next, browse to the required location on your computer.

	Type Tutorial_1 in the File name box and click Save.

	Click File > Close on the menu bar.
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Tutorial 2 
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In this example, you create the part shown below.

[image: 45.jpg]
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Creating a New document
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	Click the Windows icon located at the bottom left corner of the desktop. Next, click O > OpenSCAD.

	Click the New button on the Welcome to OpenSCAD dialog.
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Creating the Revolved Feature
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To create a revolved feature, first, you need to create a rectangle, and then revolve it.

	Type square([1,4],center=false); and press ENTER. 

	Click the Render icon on the View toolbar; the rectangle is created, as shown.
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	Click at the beginning of the square function. Next, type rotate_extrude(angle=180) and press ENTER.

	Click the Render[image: image] icon on the File toolbar; the square is rotate extruded by 180 degrees. Notice that the model is created in low resolution. You need to use the $fn function to increase the resolution of the model.
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	Click at the beginning of the script. Next, type $fn=125; and press ENTER.

	Click the Render[image: image] icon; the rotate extruded feature is smoothened.
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Creating a Revolved Cut feature
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	Click at the end of the script and press ENTER.

	Type square([0.375,0.3],center=false); and press ENTER. 

	Click the Render[image: image] icon; the rectangle is created. However, the rectangle is not visible. 

	To view the rectangle. Select the rotate_extrude and square functions above the newly created function. Next, click Edit > Comment on the menu bar, and then click the Render icon.
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––––––––
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	Click before the square function and type translate ([0.375,3.7,0]) and then press ENTER.

	Click the Render[image: image] icon; the square is translated in up to 0.375 and 3.7 distances in the X and Y directions.
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	Click at the beginning of the translate function. Next, type rotate_extrude(angle=180) and press ENTER.

	Click the Render icon on the File toolbar. The square is rotate extruded by 180 degrees
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	Select the commented rotate_extrude and square functions. Next, click Edit > Uncomment on the menu bar.
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	Click before the first rotate_extrude function.

	Type difference(){ and press ENTER.

	Close the parentheses at the end of the script.

	Click the Render icon on the View toolbar; the newly created rotate extruded feature is removed from the first one. 
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	Select the entire script except $fn=125;. Next, click Edit > Comment on the menu bar.
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	Create and translate the rectangle, as shown.
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	Click at the beginning of the translate function. Next, type rotate_extrude(angle=-180) and press ENTER.

	Click the Render icon on the View toolbar; the square is rotate extruded by 180 degrees.
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	Select the commented script. Next, click Edit > Uncomment on the menu bar.
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	Click before the difference function.

	Type union(){ and press ENTER.

	Close the parentheses at the end of the script.

	Click the Render icon on the View toolbar; the newly created rotate extruded feature is combined with the rest of the model.
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	Click the Save icon on the File toolbar. Next, browse to the required location on your computer.

	Type Tutorial_2 in the File name box and click Save.

	Click File > Close on the menu bar.
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Tutorial 3 
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In this example, you create the part shown below.[image: 46.jpg]
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Creating a New document
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	Click the Windows icon located at the bottom left corner of the desktop. Next, click O > OpenSCAD.

	Click the New button on the Welcome to OpenSCAD dialog.
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Defining the Resolution and parameters of the model
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	Type $fn=125; to define the resolution of the model.

	Likewise, enter the other parameter values, as shown.



$fn=125; 

inner_radius = 8; 

bend_radius = 20;

bend_angle = 90;

thickness = 12;

height =64;

first_armlength=46;

second_armlength=20;

third_armlength=26;

fourth_armlength=30;
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Creating the First Arm
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	Type 


//first arm 

cube([first_armlength,height,thickness], center=false); 

Next, click the Render icon to create a cube.
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Creating the First bend
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Now, you need to create a square and use the rotate_extrude function to create the revolved feature.

	Enter the following functions in the Editor window. Next, click the Render icon.


translate([inner_radius, 0, 0])

square([thickness,height],center=false);

A square is created and translated along the X-direction.

	Click at the beginning of the translate function and type rotate_extrude(angle=bend_angle)


[image: image]

	Click the Render icon; the square is revolved up to the bend_angle.
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	Click at the beginning of the rotate_extrude function and type rotate([-90,0,0]){. Next, press ENTER.

	Close the loop.
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	Click the Render icon; the revolved feature is rotated by -90 about the X-axis.


[image: image]

	Click at the beginning of the rotate function and type translate([first_armlength, 0, bend_radius]). Next, press ENTER.
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	Click the Render icon; the revolved feature is translated up to first_armlength and bend_radius distances in the X and Z-directions, respectively.


[image: image]

	Click at the beginning of the translate function and type //first_bend. Next, press ENTER. The bend comment is added to the script below. It will be easy to recognize and modify the values of the bend. You can also reuse the code to create more instances of the bend.


[image: image]

	[image: image]
	 	[image: image]


[image: image]

Creating the Second arm
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	Enter the following functions at the end of the script and press ENTER.



//second_arm

translate([first_armlength+inner_radius, 0, bend_radius])

cube([thickness,height,second_armlength], center=false);





	Click the Render icon; a cube is created. Also, it is translated up to 54 distance in the X-direction and distance of the bend_radius value in the Z-direction.
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Creating the Second bend
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	Copy the first_bend code and paste it at the end of the script.
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	Change the comment to //second_bend.
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	In the translate function, change the distance in the X-direction to first_armlength +bend_radius+inner_radius.

	In the translate function, change the distance in the Z-direction to second_armlength+bend_radius.

	In the rotate function, change the rotation angle about the Y-axis to -180.


[image: image]

	Click the Render icon; the bend is created above the second arm.
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Creating the Third arm
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	Enter the following functions at the end of the script and press ENTER.


//third_arm

translate([first_armlength+inner_radius+bend_radius, 0, bend_radius+second_armlength+inner_radius])

cube([third_armlength,height,thickness], center=false); [image: image]

	Click the Render icon; a cube is created. 
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Also, the cube is translated in the X-direction up to the distance equal to the sum of first_armlength, bend_radius, and inner_radius of the second bend. 

[image: image]

In the Z-direction, the translation distance is the bend_radius, second_armlength, and inner_radius of the second bend.
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Creating the Third bend
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	Copy the second_bend code and paste it at the end of the script.
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	Change the comment to //third_bend.
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	In the translate function, change the distance in the X-direction to first_armlength +bend_radius+inner_radius+third_armlength.

	In the rotate function, change the rotation angle about the Y-axis to -90.


[image: image]

	Click the Render icon; the bend is created next to the third arm.
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Creating the Third arm
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	Enter the following functions at the end of the script and press ENTER.



//fourth_arm

translate([first_armlength+inner_radius+2*bend_radius+third_armlength, 0, bend_radius+second_armlength])

rotate([0,180,0])

cube([thickness,height,fourth_armlength], center=false);




	Click the Render icon; a cube is created. 
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Also, the cube is translated in the X-direction up to the distance equal to the sum of first_armlength, 2 X bend_radius,  inner_radius of the second bend, and third _armlength. 

[image: image]

In the Z-direction, the translation distance is the bend_radius, and second_armlength.

[image: image]

	Add the union(){ Boolean operation before the //first arm comment. Next, press ENTER.
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	Close the loop at the end of the script, as shown.
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Creating the Holes
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	Type //chamfered_hole at the end of the script. Next, press ENTER.

	Type cylinder(66,d=21,false);to create a cylinder of 66 height and 21 diameter.

	Press ENTER and type cylinder(h=1.3, r1=10.5, r2=12, center=false);

	Click the Render icon; another cylinder with a height of 1.3, a start radius of 10.5, and an end radius of 12 is created.
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	Click before the second cylinder and type translate([0,0,64.7]). The second cylinder is translated up to a distance of 64.7 in the Z-direction.
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	Click before the first cylinder and rotate([0,90,0]){. 

	Next, close the parentheses } at the end of the script. The two cylinders are rotated by 90 degrees about the Y-axis.
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	Click before the rotate([0,90,0]) function and type translate([54,32,33]). The rotated cylinders are translated.
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	Add the difference(){ Boolean operation before the union(){ operation. Next, press ENTER.
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	Close the loop at the end of the script, as shown.
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	Click the Render icon to create the chamfered hole.
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	At the bottom of the script, click inside the closed-loop and press ENTER.
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	Enter the //second_hole comment.

	Enter the translate() and cylinder () functions with the values, as shown.
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	Click the Render icon to create another hole.
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	Click at the end of the cylinder( 74,d=20,false); function and press ENTER.

	Enter the //third_hole comment.

	Enter the translate() and cylinder () functions with the values, as shown.
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	Click the Render icon to create another hole.
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	Likewise, create the fourth hole by using the cylinder and translate functions.
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Creating Chamfers 

[image: image]


	Click at the end of the cylinder( 12,d=10,false); function and press ENTER.

	Enter the //first_chamfer comment.

	Enter the polygon function and enter the three points of the polygon in the brackets, as shown.
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	Click at the beginning of the polygon ([[0,0],[10,0],[0,20]]); function.

	Type linear_extrude(height = 12, center = false) and press ENTER. The polygon is extruded in the linear direction up to 12 distance. Also, the extrusion is not centered.

	Click the Render icon to perform the difference operation between the linear extrusion and the remaining volume.


[image: image]

	Click at the end of the polygon ([[0,0],[10,0],[0,20]]); function and press ENTER.

	Enter the //second_chamfer comment.

	Enter the linear_extrude and polygon functions, as shown.
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	Click at the beginning of the linear_extrude(height = 12, center = false) function.

	Type translate([0,24,0])and press ENTER.
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	Click the Render icon to perform the difference operation between the linear extrusion and the remaining volume.
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	Likewise, create two chamfers, as shown.



//third_chamfer

translate([120,0,10])

rotate([0,-90,0]){

linear_extrude(height = 12, center = false)

polygon([[0,0],[10,0],[0,10]]);

}

//fourth_chamfer

translate([108,64,10])

rotate([180,-90,0]){

linear_extrude(height = 16, center = false)

polygon([[0,0],[10,0],[0,10]]);

}
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	Click the Save icon on the File toolbar. Next, browse to the required location on your computer.

	Type Tutorial_1 in the File name box and click Save.

	Click File > Close on the menu bar.
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Tutorial 4
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In this example, you create the part shown next.
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Creating a New document
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	Click the Windows icon located at the bottom left corner of the desktop. Next, click O > OpenSCAD.

	Click the New button on the Welcome to OpenSCAD dialog.
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Creating the Body
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	Type $fn=125; to define the resolution of the model.

	Type cube([130,80,50]); and click the Render icon.
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Creating the Extruded features
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	Click the New icon on the File toolbar.
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	Type cube([30,25,30]); and click the Render icon.
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Next, you need to add fillets to the edges of the cube. You can add fillets using the sphere () and minkowski() functions.

	Type sphere(d=4); below the cube() function. 

	Click the Render icon. A sphere of 4 diameter is created.


[image: image]

Next, you need to apply the minkowski()function between the cube and sphere.

	Click at the beginning of the cube() function.

	Type minkowski(){.

	Next add } at the end of the sphere() function.


[image: image]

	Click the Render icon. The sphere is transformation along all the edges of the cube. As a result, the edges are rounded. Also, notice that the size of the cube is increased by the radius of the sphere on all sides.
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	Click at the beginning of the minkowski() function.

	Type translate([-2,-2,22]) and press ENTER.

	Click the Render icon.


[image: image]

Next, you need to remove the material from the main body using the filleted cube.

	Select the entire script. Next, right-click and select Copy.
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	Switch to the window of the main part.

	Right-click below the cube() function, and then select Paste.
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	Click at the beginning of the cube() function.

	Type difference(){ and press ENTER.

	Next, add } at the end of the script.
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	Click the Render icon. The filleted cube is removed from the main body.
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Creating the Rectangular Pattern of the Cut Features
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In OpenSCAD, you can pattern the objects using the For loop and translate function.

	Click at the end of the cube([130,80,50]);function, and then press ENTER.
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	Type for (x=[0:104:104]){ and press ENTER. This defines the x variable and its parameters. 


x = variable

0 = start (initial position)

104 = increment

104 = end (end position)

	Type translate([x,0,0]){and press ENTER. 

	Close the for and translate loops. 


[image: image]

	Click the Render icon. The rounded cut feature is patterned along the x axis.


[image: image]

Next, you need to pattern the cut feature in the Y-direction.

	Click after for (x=[0:104:104]){ and press ENTER.
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	Type for (y=[0:58:58]){ and press ENTER. It defines the y variable and its parameters. 


y = variable

0 = start (initial position)

58 = increment

58= end (end position)

	Change the Y coordinate value of the translate function to y.

	Close the new for loop.
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	Click the Render icon. The rounded cut feature is patterned along the y axis.
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Creating the Hole features
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	Click the New icon on the File toolbar.
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	Enter the following script to created two cylinders.



cylinder(18,d=8,false);

translate([0,0,18])

cylinder(3,d=18,false);



	Click the Render icon.
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	Click at the beginning of the cylinder() function.

	Type translate([15,12,0]){ and press ENTER.

	Next, add } at the end of the script.


translate([15,12,0]){ 

cylinder(18,d=8,false);

translate([0,0,18])

cylinder(3,d=18,false);

}

	Click the Render icon. The two cylinders are translated in the X and Y directions.
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	Add the for and translate loops to create the rectangular pattern of the cylinders.


for (x=[0:100:100]){

for (y=[0:56:56]){

translate([x,y,0]){

	Close the for and translate loops.
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	Click the Render icon.
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	Select the entire script. Next, right-click and select Copy.

	Switch to the window of the main part.

	Click at the closing parentheses of the for loop, and then press ENTER.


[image: image]

	Right-click, and then select Paste.


[image: image]

	Click the Render icon. The cylinders are removed from the main body resulting in counterbored holes.


[image: image]

	Click the New icon on the File toolbar.

	Enter the following script to created two cylinders.


cylinder(65,d=40,false);

translate([0,0,65])

cylinder(15,d=50,false);

	Rotate the cylinders using the rotate function.


rotate([90,0,0]){

cylinder(65,d=40,false);

translate([0,0,65])

cylinder(15,d=50,false);

}

	Translate the cylinders by a distance of 65, 80, and 50 along the X, Y, and Z directions, respectively.


translate([65,80,50])

rotate([90,0,0]){

cylinder(65,d=40,false);

translate([0,0,65])

cylinder(15,d=50,false);

}
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	Select the entire script. Next, right-click and select Copy.

	Switch to the window of the main part.

	Click after the closing parentheses of the for loop, and then press ENTER.
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	Right-click, and then select Paste.
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	Click the Render icon on the File toolbar.
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	Click the New icon on the File toolbar.

	Type cylinder(h=3, r1=0, r2=6, center=false); and press ENTER.


h=height of the cylinder

r1=start radius of the cylinder

r2=end radius of the cylinder.

Next, you need to create another cylinder and translate it up to 3 distance in the Z direction.

	Type translate([0,0,3]) and press ENTER.

	Type cylinder(20,d=12,false);


Height of the cylinder = 20

Diameter = 12.

	Click the Render icon.
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	Translate the cylinders by a distance of 15, 40, and 30 along the X, Y, and Z directions, respectively.


translate([15,40,30]){

cylinder(h=3, r1=0, r2=6, center=false);

translate([0,0,3])

cylinder(20,d=12,false);

}

}

	Click the Render icon.
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	Add the for and translate loops to create the linear pattern of the cylinders along the X-direction.


for (x=[0:100:100]){

translate([x,0,0]){

	Close the for and translate loops.
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	Click the Render icon.
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	Select the entire script. Next, right-click and select Copy.

	Switch to the window of the main part.

	Click after the closing parentheses of the rotate loop, and then press ENTER.
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	Right-click, and then select Paste.
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	Click the Render icon. The cylinders are removed from the main body resulting in a linear pattern of holes.
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Creating the Extruded cut feature
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	Click the New icon on the File toolbar.

	Enter the polygon function and enter the three points of the polygon in the brackets, as shown.


polygon([[36.7,0],[93.3,0],[90,8],[40,8],]);

[image: image]

	Click at the beginning of the polygon([[36.7,0],[93.3,0],[90,8],[40,8],]);function.

	Type linear_extrude(height = 80, center = false) and press ENTER. The polygon is extruded in the linear direction up to 80 distance. Also, the extrusion is not centered.

	Click the Render icon.


[image: image]

	Rotate the model using the rotate function.


rotate([90,0,0])

linear_extrude(height = 80, center = false) 

polygon([[36.7,0],[93.3,0],[90,8],[40,8],]);

	Translate the model by a distance of 80 along the Y direction, respectively.


translate([0,80,0])

rotate([90,0,0])

linear_extrude(height = 80, center = false) 

polygon([[36.7,0],[93.3,0],[90,8],[40,8],]);
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	Select the entire script. Next, right-click and select Copy.

	Switch to the window of the main part.

	Click after the closing parentheses of the for loop, and then press ENTER.
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	Right-click, and then select Paste.

	Click the Render icon on the File toolbar.
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	Click the Save icon on the File toolbar.

	Type Tutorial_4 in the File name box and click Save.

	Close the file. 
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Tutorial 5 

[image: image]


In this example, you create the part shown below.

[image: 27.jpg]
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Creating a New document

[image: image]


	Click the Windows icon located at the bottom left corner of the desktop. Next, click O > OpenSCAD.

	Click the New button on the Welcome to OpenSCAD dialog.
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Using the Hull function
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	Type the following two parameters.


v1=340;

v2=170;

v3=338;

v4=168;

	Type the following script to create two extruded cylinders, as shown.


translate([0,0,40])

cylinder(h=0.0001,d=340);

translate([225,0,355])

cylinder(h=0.0001,d=170);

	Click the Render icon.
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	Click at the beginning of the first translate () function.

	Type hull(){.

	Close the loop at the end of the script.


hull(){

translate([0,0,40])

cylinder(h=0.0001,d=d1);

translate([225,0,355])

cylinder(h=0.0001,d=d2);

}

	Click the Render icon.
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[image: image]

Using a Module
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	Click at the beginning of the hull(){function.

	Press Enter.

	Type module loft (d1,d2){


loft = name of the module

d1 and d2 are parameters of the module.

	Change the d values of the first and second cylinders to d1 and d2, respectively.

	Close the loop at the end of the script.


module loft (d1,d2){

hull(){

translate([0,0,40])

cylinder(h=0.0001,d=d1);

translate([225,0,355])

cylinder(h=0.0001, d=d2);

}

}

Now, the module is defined, and you need to use the module to create features.

	Type loft (d1=v1,d2=v2);

	Click the Render icon to create the loft feature.
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Mirroring the Loft module
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	Type mirror([1,0,0]) loft (d1=v1,d2=v2);

	Click the Render icon to mirror the loft feature about the X axis.
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	Create three cylinders by entering the script, as shown.


cylinder(h=40,d=v1);

translate([225,0,355])

cylinder(h=40,d=v2);

translate([-225,0,355])

cylinder(h=40,d=v2);

Next, you need to combine all the solids using the union()Boolean operation.

	Click at the beginning of loft (d1=v1,d2=v2);

	Type union(){ and press ENTER.

	Close the loop at the end of the script.


union(){ 

loft (d1=v1,d2=v2);

mirror([1,0,0]) loft (d1=v1,d2=v2);

cylinder(h=40,d=v1);

translate([225,0,355])

cylinder(h=40,d=v2);

translate([-225,0,355])

cylinder(h=40,d=v2);

}
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Shelling the Model geometry
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	Select the union(){ loop.

	Right-click and select Copy.

	Click at the end of the script and press ENTER.

	Right-click and select Paste.

	Modify the values of the script, as shown


union(){ 

loft (d1=v3,d2=v4);

mirror([1,0,0]) loft (d1=v3,d2=v4);

cylinder(h=40,d=v3);

translate([225,0,355])

cylinder(h=40,d=v4);

translate([-225,0,355])

cylinder(h=40,d=v4);

}

	Enclose the two union() operations inside a difference () operation, as shown.


difference (){

union(){ 

loft (d1=v1,d2=v2);

mirror([1,0,0]) loft (d1=v1,d2=v2);

cylinder(h=40,d=v1);

translate([225,0,355])

cylinder(h=40,d=v2);

translate([-225,0,355])

cylinder(h=40,d=v2);

}

union(){ 

loft (d1=v3,d2=v4);

mirror([1,0,0]) loft (d1=v3,d2=v4);

cylinder(h=40,d=v3);

translate([225,0,355])

cylinder(h=40,d=v4);

translate([-225,0,355])

cylinder(h=40,d=v4);

}

}

	Click the Render icon to shell the model.
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	Click the Save icon on the File toolbar.

	Type Tutorial_5 in the File name box and click Save.

	Close the file. 
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Tutorial 6 
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In this example, you create the part shown below.

[image: image]

[image: 44.jpg]
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Creating a New document
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	Click the Windows icon located at the bottom left corner of the desktop. Next, click O > OpenSCAD.

	Click the New button on the Welcome to OpenSCAD dialog.
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Creating Pipes
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	Type the following two parameters.


d1=65;//outer diameter of the pipe

d2=51;//outer dimeter of the pipe

ir=5;//inner radius of the elbow

x=(d1/2+ir);//outer radius of the elbow

h1=254-x;//height of the first pipe

h2=508-2*x;//height of the second and third pipes

h3=381-2*x;//height of the fourth pipe

h4=h1;//height of the fifth pipe

	Type the following script to create the pipe module, as shown.


module pipe(h,diameter1,diameter2) {

difference(){

cylinder(h,d=diameter1,center=false);

cylinder(h,d=diameter2,center=false);

}

}

	Type the following script to create a pipe and rotate it by 90 degrees about the Y axis, as shown.


rotate([0,90,0]){

pipe(h=h1,diameter1=d1,diameter2=d2);

}

	Click the Render icon.
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	Type the following script to create a pipe and translate it in the X and Z directions, as shown.


translate([h1+x,0,x]){

pipe(h=h2,diameter1=d1,diameter2=d2);

}

	Click the Render icon.
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	Type the following script to create a pipe and rotate and translate it, as shown.


translate([h1+2*x,0,h2+2*x])

rotate([0,90,0])

pipe(h=h2,diameter1=d1,diameter2=d2);

	Click the Render icon.
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	Type the following script to create a pipe and rotate and translate it, as shown.


translate([h1+h2+3*x,0,h2-h3+x]){

pipe(h=h3,diameter1=d1,diameter2=d2);

}

	Click the Render icon.
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	Type the following script to create a pipe and rotate and translate it.


translate([h1+h2+4*x,0,h2-h3])

rotate([0,90,0]){

pipe(h=h4,diameter1=d1,diameter2=d2);

}

	Click the Render icon.
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Creating Elbows
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	Type the following script to create the elbow module, as shown.


module elbow(a) {

rotate_extrude(angle=a){

difference(){

translate([d1/2+5,0,0]) circle(d=d1);

translate([d1/2+5,0,0]) circle(d=d2);

}

}

}

	Type the following script to create an elbow and rotate and translate it.


translate([h1,0,x]) 

rotate([-90,0,0]){

elbow(a=90);

}

	Click the Render icon.
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	Type the following script to create an elbow and rotate and translate it.


translate([h1+d1+2*ir,0,h2+x]) 

rotate([90,-90,0]){

elbow(a=90);

}

	Click the Render icon.
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	Type the following script to create an elbow and rotate and translate it.


translate([h1+h2+2*x,0,h2+x]) 

rotate([90,0,0]){

elbow(a=90);

}

	Type the following script to create an elbow and rotate and translate it.


translate([h1+h2+4*x,0,h2-h3+x]) 

rotate([-90,90,0]){

elbow(a=90);

}

	Click the Render icon.
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Creating the Flanges
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	Type the following script to create three cylinders and perform the difference() operation.


difference(){

cylinder(h=20,d=115,center=false);

cylinder(h=20,d=51,center=false);

translate([45,0,0])

cylinder(h=20,d=12,center=false);

}

	Click the Render icon.


[image: image]

Next, you need to create a circular pattern of the hole.

	Click at the end of the cylinder(h=20,d=51,center=false); function, and then press ENTER.

	Type for (z=[0:60:360]){ and press ENTER. It defines the z variable and its parameters. 


z = variable

0 = start (initial position)

60 = increment

360 = end (end position)

	Type rotate([0,0,z]) and press ENTER. 

	Close the for loop. 


difference(){

cylinder(h=20,d=115,center=false);

cylinder(h=20,d=51,center=false);

for (z=[0:60:360]){

rotate([0,0,z])

translate([45,0,0])

cylinder(h=20,d=12,center=false);

}

}

	Click the Render icon. The cylinder is patterned about the z axis.
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Next, you need to convert the flange into a module.

	Click at the beginning of the difference(){; function, and then press ENTER.

	Type the following script.


module flange (i,t) {

	Change the for (z=[0:60:360]){ function to for (z=[0:i:t]){.

	Close the module loop. 


module flange (i,t) {

difference(){

cylinder(h=20,d=115,center=false);

cylinder(h=20,d=51,center=false);

for (z=[0:i:t]){

rotate([0,0,z])

translate([45,0,0])

cylinder(h=20,d=12,center=false);

}

}

}

	Type the following script to create two flanges using the flange module.


//first_flange

translate([-20,0,0])

rotate([0,90,0])

flange (60,360);

//second_flange

translate([h1+h2+h4+4*x,0,h2-h3])

rotate([0,90,0])

flange (60,360);

	Click the Render icon.
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	Save and close the file.
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Tutorial 7
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In this example, you create the part shown below and then modify it using the editing tools.

[image: 36.jpg]

	[image: image]
	 	[image: image]
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Creating a New document

[image: image]


	Click the Windows icon located at the bottom left corner of the desktop. Next, click O > OpenSCAD.

	Click the New button on the Welcome to OpenSCAD dialog.
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Using the Hull function
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	Type the following parameters.


$fn=125;

d1=220;

d2=180;

d3=60;

d4=20;

d5=32;

d6=10;

h1=120;

h2=100;

h3=20;

h4=5;

h5=50.8;

l1=220;

l2=155;

	Type the following script to create two extruded cylinders, as shown.


cylinder(h=h1,d=d1);

translate([220,0,0])

cylinder(h=h1,d=d1);

	Click at the beginning of the first cylinder() function.

	Type hull(){.

	Close the loop at the end of the script.


hull(){

cylinder(h=h1,d=d1);

translate([220,0,0])

cylinder(h=h1,d=d1);

}

	Click the Render icon.
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Using a Module
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	Click at the beginning of the hull(){function.

	Type module slot (height, diameter, length){


slot = name of the module

height, diameter, and length are parameters of the module.

	Press Enter.

	Change the value of the cylinder and translate functions, as shown.

	Close the loop at the end of the script.


module slot (height,diameter,length){

hull(){

cylinder(h=height,d=diameter);

translate([length,0,0])

cylinder(h=height,d=diameter);

}

}

Now, the module is defined, and you need to use the module to create features.

	Type slot (height=h1,diameter=d1,length=l1);

	Click the Render icon to create the slot.
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	Type 


translate([l1,0,0])

slot (height=h3,diameter=d3,length=l2);

	Click the Render icon to create the slot.
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	Create a union () operation between the two slots.


union(){

slot (height=h1,diameter=d1,length=l1);

translate([l1,0,0])

slot (height=h3,diameter=d3,length=l2);

}

	Type 


translate([0,0,h3])

slot (height=h2,diameter=d2,length=l1);

	Create a difference() operation between the union () and the new slot.


difference(){

union(){

slot (height=h1,diameter=d1,length=l1);

translate([l1,0,0])

slot (height=h3,diameter=d3,length=l2);

}

translate([0,0,h3])

slot (height=h2,diameter=d2,length=l1);

}

	Click the Render icon to create the slot.
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Creating cylinders with fillets
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	Type the following script to create a square and circle. 


square(5);

translate([5,5,0])

circle(5);

	Perform the difference () operation between the square and the circle.


difference(){

square(5);

translate([5,5,0])

circle(5);

}

	Translate the sketch up to d3/2 distance in the X-direction.

	Use the rotate_extrude() function to revolve the sketch.


rotate_extrude(angle = 360) {

translate([d3/2,0,0])

difference(){

square(5);

translate([5,5,0])

circle(5);

}

}

	Add a cylinder to the revolved solid.


cylinder(h=h4,d=d3);

	Create the boss module and change the values of the functions, as shown.


module boss(boss_height,boss_dia){

cylinder(h=boss_height,d=boss_dia);

rotate_extrude(angle = 360) {

translate([boss_dia/2,0,0])

difference(){

square(5);

translate([5,5,0])

circle(5);

}

}

}

	Type the following script to create and translate the boss.


translate([0,0,h3])

boss(h4,d3);

	Click the Render icon to create the boss.
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	Enclose the boss module in the for loop, as shown.  


for (x=[0:110:220]){

translate([x,0,0])

translate([0,0,h3])

boss(h4,d3);

}

	Click the Render icon to create the linear pattern of the boss.
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	Select the boss module.

	Right-click and select Cut from the shortcut menu.
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	Paste the boss module below the slot module.
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	Create a union () operation between the difference () and for loop.


union(){

difference(){

union(){

slot (height=h1,diameter=d1,length=l1);

translate([l1,0,0])

slot (height=h3,diameter=d3,length=l2);

}

translate([0,0,h3])

slot (height=h2,diameter=d2,length=l1);

}

for (x=[0:110:220]){

translate([x,0,0])

translate([0,0,h3])

boss(h4,d3);

}

}

	Type the following script to create a linear pattern of the cylinders, as shown.


for (x=[0:110:220]){

translate([x,0,0])

cylinder(h=h3+h4,d=d5);

}

	Create a difference () operation between the union () and for loop.


difference(){

union(){

difference(){

union(){

slot (height=h1,diameter=d1,length=l1);

translate([l1,0,0])

slot (height=h3,diameter=d3,length=l2);

}

translate([0,0,h3])

slot (height=h2,diameter=d2,length=l1);

}

for (x=[0:110:220]){

translate([x,0,0])

translate([0,0,h3])

boss(h4,d3);

}

}

for (x=[0:110:220]){

translate([x,0,0])

cylinder(h=h3+h4,d=d5);

}

}

	Click the Render icon to create the linear pattern of the holes.
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	Type the highlighted functions inside the difference() operation, as shown.


difference(){

union(){

difference(){

union(){

slot (height=h1,diameter=d1,length=l1);

translate([l1,0,0])

slot (height=h3,diameter=d3,length=l2);

}

translate([0,0,h3])

slot (height=h2,diameter=d2,length=l1);

}

for (x=[0:110:220]){

translate([x,0,0])

translate([0,0,h3])

boss(h4,d3);

}

}

for (x=[0:110:220]){

translate([x,0,0])

cylinder(h=h3+h4,d=d5);

}

translate([l2+l1,0,0])

cylinder(h=h3,d=d4);

}

	Click the Render icon to create the hole, as shown.
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Creating the Fastening Holes
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	Create a fastening_hole module below the boss module.


module fastenning_hole(p1,p2,p3){

translate([p1,p2,p3])

cylinder(h=h5,d=d6);

}

	Create two for loops inside the difference () operation, as shown.


difference(){

union(){

difference(){

union(){

slot (height=h1,diameter=d1,length=l1);

translate([l1,0,0])

slot (height=h3,diameter=d3,length=l2);

}

translate([0,0,h3])

slot (height=h2,diameter=d2,length=l1);

}

for (x=[0:110:220]){

translate([x,0,0])

translate([0,0,h3])

boss(h4,d3);

}

}

for (x=[0:110:220]){

translate([x,0,0])

cylinder(h=h3+h4,d=d5);

}

translate([l2+l1,0,0])

cylinder(h=h3,d=d4);

for (x=[0:91.5:183]){

translate([x,0,0])

fastenning_hole(37,100,h1-h5);

}

for (x=[0:91.5:183]){

translate([x,0,0])

fastenning_hole(0,-100,h1-h5);

}

}

	Click the Render icon to create the linear pattern of the holes, as shown.
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	Create two for loops inside the difference () operation, as shown.


for (z=[0:-50:-150]){

rotate([0,0,z])

fastenning_hole(0,-100,h1-h5);

}

translate([220,0,0])

for (z=[0:-50:-150]){

rotate([0,0,z])

fastenning_hole(0,100,h1-h5);

}

	Click the Render icon to create the circular patterns of the holes, as shown.
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Creating the Fillets
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	Click the New icon on the File toolbar.

	Create a square and two circles by entering the script, as shown.


translate([321.538,30,0])

square([18.462,12.308]);

translate([220,0,0])

circle(110);

translate([340,50,0])

circle(20);

	Perform the difference () operation between the square and the two circles, as shown.


difference(){

translate([321.538,30,0])

square([18.462,12.308]);

translate([220,0,0])

circle(110);

translate([340,50,0])

circle(20);

}

	Click the Render icon.
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	Perform the linear_extrude () operation to the resultant 2D object.


linear_extrude(height = 20){

difference(){

translate([321.538,30,0])

square([18.462,12.308]);

translate([220,0,0])

circle(110);

translate([340,50,0])

circle(20);

}

}

	Click the Render icon.
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	Convert the entire script into a module.


module fillet(f){

linear_extrude(height = 20){

difference(){

translate([321.538,30,0])

square([18.462,12.308]);

translate([220,0,0])

circle(110);

translate([340,50,0])

circle(f);

}

}

}

	Select the entire script, right-click, and select Cut.

	Switch to the main document and paste the copied script below the fastening_hole module, as shown.


[image: image]

	Type the following script at the bottom to create and mirror fillets.


fillet(20);

mirror([0,1,0])

fillet(20);

	Click the Render icon.


[image: image]

	Save and close the file.
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